C Program to print Hello World for N times

Get input n and print the text "Hello World" for n times

Sample Input 1:

3

Sample Output 1:

Hello World Hello World Hello World

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i;
	printf("Enter a number:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{ 
		printf("Hello World ");
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=n) is true.

Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than n.

so the string literal "Hello World" will be printed n times.

Comments


Related Programs