C Program to print N Natural numbers in reverse

Get input n and print natural numbers from n in reverse.

Sample Input 1:

7

Sample Output 1:

7 6 5 4 3 2 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i;
	printf("Enter a number:");
	scanf("%d",&n);
	printf("First %d natural numbers in reverse order:\n",n);
	for(i=n;i>0;i--)
	{
		printf("%d ",i);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i>0) is true.

Here i is initialized to n and decremented by 1 for each iteration, instructions inside the for block are executed unless i becomes less than 1.

so value of i will be printed like n n-1 ....3 2 1 using printf statement.

Comments


Related Programs