Concate two given Strings

Get two strings and join them as a single string.

Sample Input 1:

MARK MAKE

Sample Output 1:

MARKMAKE

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
#include<string.h>
int main()
{
	char str[100],str1[50],str2[50];
	int i,j=0;
	fgets(str1,50,stdin);
	fgets(str2,50,stdin);
	
		
	for(i=0;i<strlen(str1)-1;i++,j++)
	{
		str[j]=str1[i];
	}

	for(i=0;i<strlen(str2)-1;i++,j++)
	{
		str[j]=str2[i];
	}
	printf("%s",str);
	return 0;
}

	

			
				
			

Program Explanation

Get two String using fgets() function.

Str -> reads the string and stores it in str.

50 -> reads maximum of 50 characters stdin-> reads character from keyboard First store the string str1 in str, then store str2 in str using two sequential for loops.

Comments