Java Program to find smallest among three numbers

Get three numbers num1, num2 and num3 and find the smallest one among num1,num2 and num3.

Sample Input 1:

1 6 2

Sample Output 1:

1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class SmallerTh
{
        public static void main(String args[])
        {
              int num1,num2,num3;
              Scanner sc=new Scanner(System.in);
	         System.out.println("Enter three numbers:");
              num1=sc.nextInt();
              num2=sc.nextInt();
              num3=sc.nextInt();
	
	             if(num1 < num2 && num1 < num3)
	                {
		              System.out.println("The Smallest Is"+num1);
	                }
	             else if(num2 < num3)
	                {
		               System.out.println("The Smallest Is"+num2);
	                }
	             else
	                {
		               System.out.println("The Smallest Is"+num3);
	                }	
         }
}


			
				
			

Program Explanation

1. Get three inputs num1,num2 and num3 from user using scanner class.

2. check whether num1 is smaller than num2 and num1 is smaller than num3 using if statement.

    if num1 is smaller

        2a. print num1 using print statment,

    else

        2b. check whether num1 is smaller than num3 using elseif statement.

        If num2 is smaller

            2b1. print num2 using system.out.println,

        else

            2b2. print num3 using system.out.println.

Comments