Java Program to find whether the last digit of given number is divisible by 3

Get a number num and check whether last digit of num is divisible by three.

Sample Input 1:

27

Sample Output 1:

last digit not Divisible by 3

Sample Input 2:

43

Sample Output 2:

last digit divisible by 3

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class LastDTh
{
  public static void main(String args[])
  {
     int input1,digit;
     Scanner sc=new Scanner(System.in);
     System.out.println("Enter The Input:");
     input1=sc.nextInt();
     digit=input1%10;
     if((digit)%3==0)
       {
          System.out.println("The Last Digit Is Divisible By 3.");
       }
    else
       {
          System.out.println("The Last Digit Is Not Divisible By 3.");
       }

  }

}

			
				
			

Program Explanation

1. Get input from user using scanner class

2.extract last digit from input1 using the expression digit=input1%10.

3. check whether the remainder of digit divided by 3 is equal to 0 using if statement.

    if it is 0, then

        3a. print digit is divisible by 3 using printf statement.

    Else

        3b. print digit is not divisible by 3 using system.out.println.

Comments