Java Program to print Even numbers till N

Get input n and print n even numbers.

Sample Input 1:

7

Sample Output 1:

2 4 6 8 10 12 14

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class NEven
 {
    public static void main(String args[])
    {
          int i,lim;
          System.out.println("Enter The Value Of N");
          Scanner sc=new Scanner(System.in);
          lim=sc.nextInt();
          System.out.println("The N Even Numbers: ");
          for(i=2;i<=lim;i=i+2)
              {
                   System.out.println(""+i);
              }
    }
}
			
				
			

Program Explanation

1. Get the input lim(Till which number the even numbers to be printed)

2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=lim) is true.

    for(i=2;i<=lim;i=i+2)

3. Here i is initialized to 2 and i is incremented by 2 for each iteration, instructions inside the for block are                  executed in every iteration. Iteration stops when i becomes greater than lim.

    so value of i (2,4,6,8,....) (even numbers till lim) in each iteration will be printed using system.out.println

Comments