Java Program to print N Natural numbers in reverse

Get input n and print natural numbers from n in reverse.

Sample Input 1:

7

Sample Output 1:

The natural numbers in reverse: 7 6 5 4 3 2 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class NaturalInRev
{
   public static void main(String args[])
   {
	int lim,i;
	System.out.println("Enter The Limit:");
	Scanner sc=new Scanner(System.in);
     	lim=sc.nextInt();
	System.out.println(" The Natural Numbers Is In Reverse Order:");
	for(i=lim;i>=1;i--)
	{
		System.out.print(" "+i);
      	}
    }
}
			
				
			

Program Explanation

1. Get input limit (from which number natural numbers to be printed in reverse) 

2. Instruction(s) inside the for block{} are executed repeatedly till i greater than 0. (i>0)

    for(i=lim;i>=1;i--)

3. Here i is initialized to limit and decremented by 1 for each iteration, instructions inside the for              block are executed in every iteration. Iteration stops when i becomes lesser than or equal to 0.

so value of i will be printed like limit, limit-1,limit-2.....,3,2,1 


Comments