Java Program to find simple interest

Sample Input 1:

Enter the number of years: 1 Enter the Rate: 10 Enter the Principle Amount: 1000

Sample Output 1:

100

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class SimpleInt
{
 public static void main(String args[])
 {
   int n,p;
   double rate,si;
   Scanner sc=new Scanner(System.in);
   System.out.println("Enter The Number Of Months:");
   n=sc.nextInt();
   System.out.println("Enter The Rate:");
   rate=sc.nextDouble();
   System.out.println("Enter The Principle Amount:");
   p=sc.nextInt();
   si=(p*rate*n)/100;
   System.out.println("The Simple Interest Is:"+si);
 }

}
			
				
			

Program Explanation

Get principal p, number of months n and rate of interest rate as inputs.

(using scanner class) calculate Simple Interest Si by formula Si= p*n*rate/100 print Simple Interest Si using system.out.println.

Comments