C Program to draw Inverse Pyramid Pattern

Sample Input 1 :

5

Sample Output 1 :

*********
 *******
  *****
   ***
    *

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int i,j,k,n,step;
	printf("enter row size:");
	scanf("%d",&n);
	step=2*n-1;
	for(i=1;i<=n;i++)
	{

		for(k=1;k<i;k++)
		{
			printf(" ");
		}
		for(j=1;j<=step;j++)
		{
			printf("*");
		}
		step-=2;
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video Tutorial

Comments