C Program to draw Number pattern III

 Sample Input 1 :

5

 Sample Output 1 :

    1
   121
  12321
 1234321
123454321

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int i,j,n,k,step=1,num;
	printf("enter row size:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		num=1;
		for(k=1;k<=n-i;k++)
		{
			printf(" ");
		}
		
		for(j=1;j<=step;j++)
		{
			printf("%d",num);
			if(j<i)
			{
				num++;
			}
			else
			{
				num--;
			}
			
		}

		step+=2;
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video tutorial

Comments