C Program to draw Number pattern IX

Sample Input 1:

5

Sample Output 1:

1
23
456
78910
1112131415
78910
456
23
1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{	
	int i,j,n,num=1,l;
	printf("Enter row size:");
	scanf("%d",&n);

	for(i=1;i<=n;i++)
	{
		for(j=1;j<=i;j++)
		{
			printf("%d",num);
			num++;
		}
		printf("\n");
	}

	l=2*n-1;
	for(i=1;i<n;i++)
	{
		num=num-l;
		for(j=1;j<=n-i;j++)
		{
			printf("%d",num);
			num++;
		}
	
		l=l-2;
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video tutorial

Comments