C Program to draw Number pattern VI

Sample Input 1:

5

Sample Output 1:

1
32
456
10987
1112131415

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{	
	int i,j,n,num=1,k=1;
	printf("Enter row size:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=i;j++)
		{
			if(i%2!=0)
			{
				printf("%d",num);
				num++;
			}
			else
			{
				printf("%d",num);
				num--;
			}
		}
		num=num+k;
		if(i%2!=0)
		{
			k=k+2;
		}
		printf("\n");
	}
	
	return 0;
}
			
				
			

Program Explanation

Refer Video tutorial

Comments