C Program to draw Number pattern VII

Sample Input 1:

5

Sample Output 1:

    1
   2 2
  3 3 3
 4 4 4 4
5 5 5 5 5

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{	
	int i,j,n,k;
	printf("Enter row size:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n-i;j++)
		{
			printf(" ");
		}
		for(k=1;k<=i;k++)
		{
			printf("%d",i);
			if(k!=i)
			{
				printf(" ");
			}
		}
		
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video tutorial

Comments