Program to check whether given Integer is perfect number or not

Sample Input 1 :

6

Sample Output 1:

6 is a Perfect Number (sum of factors of 6 is 6)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
    	int number, i;

    	printf("Enter a Number: ");
    	scanf("%d",&number);
	

    		for(i=1; i <= number/2; ++i)
    		{
        		if (number%i == 0)
        		{
            			sum+=i;
        		}
    		}
		if(sum==number)
		{
			printf("%d is a perfect number ",number);
		}
		else
		{
			printf("%d is not a perfect number ",number);
		}
		
	
	

    return 0;
}
			
				
			

Program Explanation

refer video tutorial

Comments