Program to find GCD of given numbers

Sample Input 1 :

12 24

Sample Output 1 :

12

Flow Chart Design

Program to find GCD of given numbers Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
    	int n,m,gcd,i;

    	printf("Enter two Numbers: ");
    	scanf("%d %d",&n,&m);

	gcd= (n<m)?n:m;
	
	while(1)
	{
		if(m%gcd==0&&n%gcd==0)
		{
			break;
		}
		gcd--;
	}

	printf("\n GCD is %d",gcd);
	return 0;
}
			
				
			

Program Explanation

refer video tutorial

Comments