Reverse the first half of list elements in python

Python Program to get list size n and n elements of list, then reverse the first n/2 elements.

Sample Input 1:

5 5 7 9 3 1

Sample Output 1:

7 5 9 3 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
l=list(map(int,input("Enter Numbers:").split()))
start=0
stop=len(l)//2 -1
while(start<stop):
    l[start],l[stop]=l[stop],l[start]
    start+=1
    stop-=1
print(l)


			
				
			

Program Explanation

initialize start to first location of list and stop to last location of list using start=0 stop=len(l)/2-1 swap the elements in location start and stop, then increment start by 1 and decrement stop by 1.

l[start],l[stop]=l[stop],l[start] repeat the above step till start is less than stop

Comments