Multiplication Table in Python

Python program to get input n and print the multiplication table of n

Sample Input 1:

4

Sample output 1:

1X4=4 2X4=8 3X4=12 4X4=16 5X4=20 6X4=24 7X4=28 8X4=32 9X4=36 10X4=40

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Multiplication Table of:"))
for i in range(1,10+1):
    print("{} X {} = {}".format(i,n,i*n))
    

			
				
			

Program Explanation

Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than10.

so value of i (1,2,3,...10)will be multiplied with n and printed in table format.

Comments