Multiplication Table in Python till M

Python program to get input n and m, print the multiplication table of n till m

Sample Input 1:

4 7

Sample output 1:

1X4=4 2X4=8 3X4=12 4X4=16 5X4=20 6X4=24 7X4=28

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Multiplication Table of:"))
m=int(input("Till:"))
for i in range(1,m+1):
    print("{} X {} = {}".format(i,n,i*n))
    

			
				
			

Program Explanation

Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than m.

so value of i (1,2,3,...m)will be multiplied with n and printed in table format.

Comments