Sum of odd numbers in pyhton

Python program to get input n and calculate the sum of odd numbers till n

Sample Input 1:

5

Sample Output 1:

9(1+3+5)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
sum=0
for i in range(1,n+1,2):
    sum+=i
print(sum)
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has 1,3,5... to n or n-1. for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it adds odd numbers.

Comments