Python Left shift Operator

Python program to get number n and m, left shit the bits of n for m times:

Sample Input 1:

4 1

Sample Output 1:

8

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter your First Number:"))
num2=int(input("Enter your Second Number:"))
num=num1<<num2
print("After Left shift: {}".format(num))

			
				
			

Program Explanation

left shift is equal to multiply a number with 2, left shift by n is equal to multiply with pow(2,n)

Comments