C Program to draw Inverse Right Staircase Pattern

 Sample Input 1 :

Sample Output 1 :

*
**
***
****
*****

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int i,j,k,n,step;
	printf("enter row size:");
	scanf("%d",&n);
	step=n;
	for(i=1;i<=n;i++)
	{

		for(j=1;j<=step;j++)
		{
			printf("*");
		}
		step-=1;
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video Tutorial

Comments