C Program to find the first digit of a number

Sample Input 1 :

734

Sample Output 1 :

First digit is 7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,num;
	scanf("%d",&num);
	n=num;
	while(num>=10)
	{
		num/=10;
	}
	printf("%d is the first digit in %d",num,n);
	return 0;
}
		
			
				
			

Program Explanation

refer video tutorial

Comments