Reverse the String in python

python program to get a String and reverse the characters of the string

Sample Input 1:

Hello

Sample Output 1 :

olleH

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
s1=input("Enter a String:")
s2=""
j=len(s1)-1
while(j>=0):
    s2+=s1[j]
    j-=1
s1=s2
print(s1)
            
            
				

			
				
			

Program Explanation

visit each location in string s1 from the last location len(l)-1 and append it to s2, finally store s2 in s1 Note: String is immutable, so you cannot modify a character directly in a orginal string.

Comments