Compare two Strings are equal

Get two strings and check whether both are equal

Sample Input 1:

MARK MAKE

Sample Output 1:

Not Equal

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
#include<string.h>
int main()
{
	char str1[50],str2[50];
	int i;
	fgets(str1,50,stdin);
	fgets(str2,50,stdin);
	if(strlen(str1)==strlen(str2))
	{	
		for(i=0;i<strlen(str1)-1;i++)
		{
			if(str2[i]!=str1[i])
			{
				printf("not equal");
				return 0;	
			}
			
		}
	}
	else
	{
		printf("not equal");
		return 0;
	}
		
	printf("Both the strings are equal");
	return 0;
}

	

			
				
			

Program Explanation

Get two String using fgets() function.

Str -> reads the string and stores it in str.

50 -> reads maximum of 50 characters stdin-> reads character from keyboard first compare the length of both the strings, if it is equal check whether each character of both the string is equal.

Else print "both are not equal".

if each character in both the string are equal print "Both are equal" Else print "both are not equal".

Comments