Count the occurences of given Character in a String

Get a String and a character then count the occurrence of character in the string.

Sample Input 1:

Hello o

Sample Output 1:

1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
#include<string.h>
int main()
{
	char str[50];
	char s,count=0;
	int i;
	fgets(str,50,stdin);
	scanf("%c",&s);
	
		
	for(i=0;i<strlen(str)-1;i++)
	{
			if(str[i]==s)
			{
				count++;
			}
		
	}
	printf("%c occured %d times",s,count);
	return 0;
}

	

			
				
			

Program Explanation

Get a String using fgets() function.

Str -> reads the string and stores it in str.

50 -> reads maximum of 50 characters stdin-> reads character from keyboard read character s using scanf() for loop iterates and check each character whether it is s. if(str[i]==s) then variable count is incremented by 1, else moves to next character.

Finally prints the count.

Comments