Java Program to find whether the difference between two numbers is even or odd

Get two numbers num1 and num2 and check whether the difference between num1 and num2 is odd or even?

Sample Input 1:

45 56

Sample Output 1:

The difference is ODD

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Checker
{
  public static void main(String args[])
  { 
     int input1,input2,diff;
     Scanner sc=new Scanner(System.in);
     System.out.println("Enter The Input 1:");
     input1=sc.nextInt();
     System.out.println("Enter The Input 2:");
     input2=sc.nextInt();
     diff=input1-input2;
     if((diff)%2==0)
       {
	 System.out.println("The Difference is Even.");
       }

    else
      {
        System.out.println("The Difference is Odd.");
      }


  }
}
			
				
			

Program Explanation

1. two inputs input1 and input2 from user using scanner class.

2. Calculate difference between input1 and input2 using the expression difference = input1 - input2.

3. check whether the remainder of difference divided by 2 is equal to 0 using if statement.

            if it is 0, then

                3a. print difference is even using system.out.println

            Else

                3b. print difference is odd using system.out.println

Comments