C Program to find the sum of array elements using pointers

Get array size n and n elements of array, then compute sum of the elements.

Sample Input 1:

5 5 7 9 3 1 

Sample Output 2:

25

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include <stdio.h>


#include <stdlib.h>
int main(void)

{
	
	
	int n,i,*a,sum=0;

	printf("Enter size of array:");
	scanf("%d",&n);

	a=calloc(sizeof(int),n);
	printf("Enter %d Elements:",n);
	for(i=0;i<n;i++)

	{

		scanf("%d",a+i);

	}

	for(i=0;i<n;i++)
	
	{

		sum=sum+*(a+i);

	}

	printf("The sum of Array is: %d",sum);	
	return 0;

}

			
				
			

Program Explanation

calloc() is predefined function allocates memory of specified bytes.

Number of bytes is specified as (4,n), it means n 4 bytes.

Since we are using integers, specified as 4 bytes.

*a denotes first four bytes, *(a+1) denotes second four bytes, *(a+2) denotes third four bytes and so on., i is initialized to 0 and incremented by 1 at each iteration of both the for loops.

 First for loop reads n input numbers from user and stores them in array a[] from location 0 to n-1

Second for loop adds all the n elements of array located from 0 to n-1

Finally prints the sum using printf statement.

Comments