Covert Lowercase characters to Uppercase Characters using Pointers

Get a String and convert the upper case characters to lower case Characters

Sample Input 1:

Hello

Sample Output 1:

hello

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
#include<stdlib.h>
int main()
{
	char *str;
	int i = 0;
	str=calloc(sizeof(char),50);
	fgets(str,50,stdin);
	while(*(str+i)!='\0')
	{
		if(*(str+i)>=97 && *(str+i)<=122)
		{
			*(str+i)=*(str+i)-32;
		}
		i++;
	}
	printf("%s",str);
	return 0;
}

	

			
				
			

Program Explanation

Get a String using fgets() function.

Str -> reads the string and stores it in str.

50 -> reads maximum of 50 characters stdin-> reads character from keyboard ASCII value of A to Z is 65 - 90 and a to z is 97 to 122.

for loop iterates and check each character whether it is s A to Z, if it is in A to Z then increment it with 32 to get Lower Case.

Comments