Java Program to find the Second Largest Number in the Array

Get array size n and n elements of array, then find the second largest element among those elements.

Sample Input 1:

5

5 7 9 3 1

Sample Output 1:

7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
//To Find Second Largest Element In The Array...

import java.util.*;

class Program
{
  public static void main(String args[])
   {
      int size,i;
      Scanner sc=new Scanner(System.in);

      System.out.println("Enter The Size Of The Array:");
      size=sc.nextInt();

      int a[]=new int[size];
      int c[]=new int[size-1];

      System.out.println("Enter The Array Elements:");

      for(i=0;i<size;i++)
       {
           a[i]=sc.nextInt();
       }

      int max=a[0];
      for(i=0;i<size;i++)
       {

          if(max<a[i])
           {
                 max=a[i];
           }

      }

      System.out.println("The First Largest Element In The Array Is:"+max);

      int j=0;
     for(i=0;i<size;i++)
     {
          if(a[i]<max)
           {
               c[j]=a[i];
               j++;
           }

       }


    int max1=c[0];
    for(i=0;i<size-1;i++)
    {
         if(max1<c[i])
         {
              max1=c[i];
         }
    }

    System.out.println("The Second Largest Element In The Array Is:"+max1);

  }
}

			
				
			

Program Explanation

Comments