Java Program to Reverse the First Half Elements of Array

Get array size n and n elements of array, then reverse the first n/2 elements.

Sample Input 1:

5

5 7 9 3 1

Sample Output 1:

7 5 9 3 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
//To Reverse The First Half Of Array Elements...

import java.util.*;

class Program
{
  public static void main(String args[])
   {
     int size,i,j;
     Scanner sc=new Scanner(System.in);

     System.out.println("Enter The Size Of The Array:");
     size=sc.nextInt();

     int a[]=new int[size];

     System.out.println("Enter The Array Elements:");

     for(i=0;i<size;i++)
     {
         a[i]=sc.nextInt();
     }


     for(i=0,j=(size/2)-1;i<j;i++,j--)
       {
          int temp=a[i];
          a[i]=a[j];
          a[j]=temp;
        }

    System.out.println("The Output Is:");
    for(i=0;i<size;i++)
      {
        System.out.println(" "+a[i]);
       }

   }
}

			
				
			

Program Explanation

Comments