Python Program to replace every element with the greatest element on right side

Python Program to get list size n and n elements of list, replace every elements with the greatest element located in right side.

Sample Input 1:

5 5 7 9 3 1

Sample Output 1:

9 9 3 3 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
l=list(map(int,input("Enter numbers:").split(" ")))
for i in range(0,len(l)-1):
    max1=l[i+1]
    for j in range(i+2,len(l)):
        if(l[j]>max1):
            ind=j
            max1=l[j]
    l[i]=l[ind]

print(l)

			
				
			

Program Explanation

visit each location in list find the greatest element (max1)next to the location using Store the max1 in current location by l[i] = max1

Comments