Java Program to calculate sum of ODD numbers till N
Get input n and calculate the sum of odd numbers till n
Sample Input 1:
5
Sample Output 1:
The Sum Of odd Number Till N:9(1+3+5)
Program or Solution
import java.util.*;
class SumOfNOdd
{
public static void main(String args[])
{
int i,j,N,sum=0;
System.out.println("Enter The Value Of N");
Scanner sc=new Scanner(System.in);
N=sc.nextInt();
System.out.println("The N Odd Numbers: ");
for(i=1;i<=N;i+=2)
{
sum=sum+i;
}
System.out.println("The Sum Of N Odd Numbers: "+sum);
}
}
Program Explanation
1. Get input N (To which odd numbers to be added)
2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=N) is true.
for(i=1;i<N;i+=2)
3. Here i is initialized to 1 and incremented by 2 for each iteration, instructions inside the for block are executed in every iteration. iteration stops when i becomes greater than n.
so value of i (1,3,5,...n)will be added to sum.
sum = sum + i
sum = 0 + 1
sum = 1 + 3
sum = 4 + 5
...................
after adding all odd numbers till N to sum, sum will be printed using system.out.println.
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
coming Soon
coming Soon