C Program to get and print the array elements

Get array size n and n elements of array, then print the elements.

Sample Input 1:

5 5 7 9 3 1

Sample Output 1:

5 7 9 3 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include <stdio.h>
#include <stdlib.h>


int main(void)

{
	
	int *a,n,i;

	printf("Enter size of array:");
	scanf("%d",&n);

	a=malloc(sizeof(int)*n);

	printf("Enter %d Elements:",n);
	for(i=0;i<n;i++)

	{

		scanf("%d",&a[i]);

	}

	printf("Array elements are:\n");
	for(i=0;i<n;i++)
	
	{

		printf("%d ",a[i]);

	}
	
	return 0;

}
			
				
			

Program Explanation

i is initialized to 0 and incremented by 1 at each iteration of both the for loops.

for loop reads n input numbers from user and stores them in array a[] from location 0 to n-1 Second for loop

prints the n elements of array located from 0 to n-1.

Comments