Java Program to calculate bytes to kilobytes

Get bytes b from user and find kilobytes kb

Sample Input 1:

2048

Sample Output 1:

2

Sample Input 2:

1024

Sample Output 2:

1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Converter
{
   public static void main(String args[])
   {
       Double kilobytes,bytes;
       Scanner sc=new Scanner(System.in);
       System.out.println("Enter The Bytes:");
       bytes=sc.nextDouble();
       kilobytes=bytes/1024;
       System.out.println("The KiloBytes Is:"+kilobytes);
   }
}
			
				
			

Program Explanation

Get bytes Byt as input (using scanner class) Calculate kilobytes Kilo by dividing bytes Byt by 1024. (kb=b/1024, 1024 bytes is equal to 1 kilobyte) Print kilobytes kb (using System.out.println)

Comments