Java Program to print the last digit of given number N

Get an number n from user and display the last digit of n

Sample Input 1:

623

Sample Output 1:

3

Sample Input 2:

280

Sample Output 2:

0

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class LastD
{
  public static void main(String args[])
  {
     int input1,digit;
     Scanner sc=new Scanner(System.in);
     System.out.println("Enter The Input:");
     input1=sc.nextInt();
     digit=input1%10;
     System.out.println("The Last Digit is:"+digit);
  }

}

			
				
			

Program Explanation

Get a input input1 (using scanner class) Seprate the last digit of number num by "digit = input%10".

(% by 10 always gives last digit of a number) print the digit (using system.out.println)

Comments