C Program to draw Number pattern V

 Sample Input 1 :

5

 Sample Output 1 :

111112
322222
333334
544444
555556

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{	
	int i,j,n,num=1;
	printf("Enter row size:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		if(i%2==0)
		{
			printf("%d",num+1);
		}
		for(j=1;j<=n;j++)
		{
			printf("%d",num);
		}
		if(i%2!=0)
		{
			printf("%d",num+1);
		}
		num++;
		printf("\n");
	}
	return 0;
}
			
				
			

Program Explanation

Refer Video tutorial

Comments