C Program to check odd or even using bitwise operator

Get a number num and check whether num is odd or even using bit wise operator.

Sample Input 1:

45

Sample Output 1:

ODD

Sample Input 2:

56

Sample Output 2:

EVEN

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a number:");
	scanf("%d",&num);
	if((num&1)==0)
	{
		printf("%d is Even",num);
	}
	else
	{
		printf("%d is Odd",num);
	}
	return 0;
}
			
				
			

Program Explanation

last bit(LSB) is 0 for all even numbers and 1 for all odd numbers.

Example : 2 - 0000 0010, 8 - 0000 1000 and 5 - 0000 0101

Comments