C Program to find whether the given number is divisible by 3

Get a number num and check whether num is divisible by 3.

Sample Input 1:

27

Sample Output 1:

Divisible by 3

Sample Input 2:

43

Sample Output 2:

Not divisible by 3

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a number: ");
	scanf("%d"&num);
	if(num%3==0)
	{
		printf("%d is divisible by 3",num);
	}
	else
	{
		printf("%d is not divisible by 3",num);
	}
	return 0;
}
			
				
			

Program Explanation

Get input num from user using scanf statement

check whether the remainder of num divided by 3 is equal to 0 using if statement.

if it is 0, then print num is divisible by 3 using printf statement.

Else print num is not divisible by 3 using printf statement.

Comments