C Program to find whether the difference between two numbers is even or odd

Get two numbers num1 and num2 and check whether the difference between num1 and num2 is odd or even?

Sample Input 1:

45 56

Sample Output 1:

ODD

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num1,num2,difference;
	printf("Enter two numbers:");
	scanf("%d %d"&num1,&num2);
	difference=num1-num2;
	if(difference%2==0)
	{
		printf("The difference %d is even",difference);
	}
	else
	{
		printf("The difference %d is odd",difference);
	}
	return 0;
}
			
				
			

Program Explanation

Get two inputs num1 and num2 from user using scanf statement

Calculate difference between num1 and num2 using the expression difference = num1 - num2.

check whether the remainder of difference divided by 2 is equal to 0 using if statement.

if it is 0, then print difference is even using printf statement.

Else print difference is odd using printf statement.

Comments