C Program to find smallest among two numbers

Get two numbers num1 and num2 and find the smallest one among num1 and num2.

Sample Input 1:

5 6

Sample Output 1:

5

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include <stdio.h>


int main(void)
{

	int num1,num2;

	printf("Enter two numbers:");
	scanf("%d %d",&num1,&num2);

	if(num1<num2)

	{
		
		printf("%d is smaller",num1);
	
	}
	
	else if(num2<num1)

	{

		printf("%d is smaller",num2);
	
}

	else

	{

		printf("%d and %d are equal",num1,num2);

	}

	return 0;

}

			
				
			

Program Explanation

Get two inputs num1 and num2 from user using scanf statement

check whether num1 is smaller than num2 using if statement.

if num1 is smaller print num1 using printf statment, else check whether num2 is smaller than num1 using elseif statement.

If num2 is smaller print num2 using printf statement, else print num1 and num2 are equal using printf statment.

Comments