C Program to find the whether the last digit of given two numbers are equal or not

Get two numbers num1 and num2 and check whether last digit of num1 and num2 are equal or not?.

Sample Input 1:

65 45

Sample Output 1:

Equal 

Sample Input 2:

35 38

sample Output 2:

Not Equal

Flow Chart Design

C Program to find the whether the last digit of given two numbers are equal or not Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num1,num2;
	printf("Enter two numbers:");
	scanf("%d %d"&num1,&num2);
	if(num1%10==num2%10)
	{
		printf("%d and %d are equal",num1%10,num2%10);
	}
	else
	{
		printf("%d and %d are not equal",num1%10,num2%10);
	}
	return 0;
}
			
				
			

Program Explanation

extract the last digits of num1 and num2 using %10, then compare last digits.

Comments