C Program to Print the given word

Get a Word from user and display the same.

Sample Input 1:

hello

Sample Output 1:

hello

Sample Input 2:

hi boss

Sample Output 2:

hi

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
//Program to print the given word
#include<stdio.h>
int main()
{
	char msg[50];
	printf("Enter a word:");
	scanf("%s",&msg);	 
	printf("\nEntered word: %s",msg);	
	return  0;
}
			
				
			

Program Explanation

scanf is a function available(predefined) in c library to get input from user via keyboard and stores the same in a variable.

Here it reads input string and stores it in a variable str1.

Format Specifier "%s" reads input as string and terminates read operation while entering space or enter button.

printf is a function available(pre defined) in C library which is used to print the specified content in Monitor.

Here it prints the value of the variable str1.

Format Specifier "%s" prints value as String.

Comments