C Program to print given octal number in integer format

Get a Octal number from user and display the corresponding integer value

Sample Input 1:

24

Sample Output 1:

20

Sample Input 2:

10

Sample Output 2:

8

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
//Program to print the given octal number in integer format
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a octal number:");
	scanf("%o",&num); 	
	printf("\nEquivalent Decimal value: %d",num);	
	return  0;
}
			
				
			

Program Explanation

scanf is a function available(predefined) in c library to get input from user via keyboard and stores the same in a variable.

Here it reads input number and stores it in a variable num.

Format Specifier "%o" reads input as Octal number.

printf is a function available(pre defined) in C library which is used to print the specified content in Monitor.

Here it prints the value of the variable num.

Format Specifier "%d" prints value as Integer number (d for decimal number system).

Comments