C Program to print the ASCII value of a character

Get a character from user and display the corresponding ASCII value

Sample Input 1:

A

Sample Output 1:

65

Sample Input 2:

J

Sample Output 2:

74

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
//Program to print the ASCII value of given Character
#include<stdio.h>
int main()
{
	char ch;
	printf("Enter a character:");
	scanf("%c",&ch); 	
	printf("Equivalent ASCII value: %d",ch);	
	return  0;
}
			
				
			

Program Explanation

scanf is a function available(predefined) in c library to get input from user via keyboard and stores the same in a variable.

Here it reads input character and stores it in a variable ch.

Format Specifier "%c" reads single character.

printf is a function available(pre defined) in C library which is used to print the specified content in Monitor.

Here it prints the value of the variable ch.

Format Specifier "%d" prints value as Integer number (character converted to ASCII).

Comments