C Program to print the character for given ASCII value

Get a ASCII value from user (0 to 255) and display the corresponding character

Sample Input 1:

75

Sample Output 1:

K

Sample Input 2:

97

Sample Output 2:

a

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
//Program to print the character of given ASCII value
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a ASCII value(0 to 255)");
	scanf("%d",&num); 	
	printf("Equivalent Character: %c",num);	
	return  0;
}
			
				
			

Program Explanation

scanf is a function available(predefined) in c library to get input from user via keyboard and stores the same in a variable.

Here it reads input number and stores it in a variable num.

Format Specifier "%d" reads Input as integer number.

printf is a function available(pre defined) in C library which is used to print the specified content in Monitor.

Here it prints the value of the variable num.

Format Specifier "%c" prints value as character (ASCII Converted to Character).

Comments