C Program to print the given integer number

Get a number from user and display the same

Sample Input 1:

56

Sample Output 1:

56

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
//Program to print the given Integer (whole) number
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a number:");
	scanf("%d",&num); 	
	printf("Entered number:%d",num);	
	return  0;
}
			
				
			

Program Explanation

scanf is a function available(predefined) in c library to get input from user via keyboard and stores the same in a variable.

Here it reads input number and stores it in a variable num.

Format Specifier "%d" reads input as integer number.

(d for decimal number system) printf is a function available(pre defined) in C library which is used to print the specified content in Monitor.

Here it prints the value of the variable num.

Format Specifier "%d" prints value as Integer.

Comments