Program to Print the Perfect squares between two intervals

Sample Input 1:

1 100

Sample Output 1 :

1 4 9 16 25 36 49 64 81 100

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
# include <stdio.h>
# include <math.h> 
int main() 
{ 
	 int m, n,start,stop; 
	 float p ; 
  
	printf("Enter two numbers : ") ; 
 	scanf("%d %d", &start,&stop) ; 
 	
	for(n=start;n<=stop;n++)
	{
		p = sqrt(n) ; 
 		m = p ; 
 		if (p == m) 
  			printf("%d ", n) ; 
 		  		
	}
	
 	return 0;
} 
			
				
			

Program Explanation

refer video tutorial

Comments