Program to check whether given Integer is Prime or Not

Sample Input 1:

11

Sample Output 1 :

11 is a Prime Number

Sample Input 2 :

12

Sample Output 2 :

12 isnot a Prime Number

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include <stdio.h>
int main()
{
    int number, i;

    printf("Enter a Number: ");
    scanf("%d",&number);

    for(i=2; i<=number/2; ++i)
    {
       
        if(number%i==0)
        {
            printf("%d is not a prime number.",number);
            return 0;
        }
    }


    printf("%d is a prime number.",number);
             
    return 0;
}
			
				
			

Program Explanation

refer video tutorial

Comments