Program to check whether given Integer is Perfect Square or not

Sample Input 1:

49

Sample Output 1 :

49 is a Perfect Square (7*7=49)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
# include <stdio.h>
# include <math.h> 
int main() 
{ 
	int m, n ; 
	float p ; 
  
	printf("Enter a number : ") ; 
 	scanf("%d", &n) ; 
 	p = sqrt(n) ; 
 	m = p ; 
 	if (p == m) 
  		printf("\n%d is a perfect square", n) ; 
 	else 
  		printf("\n%d is not a perfect square", n) ; 
 	return 0;
} 
			
				
			

Program Explanation

refer video tutorial

Comments