C Program to get and print the array elements using pointers

Get array size n and n elements of array, then print the elements.

Sample Input 1:

5 5 7 9 3 1

Sample Output 1:

5 7 9 3 1

Program or Solution

				
			
					
#include<stdio.h>


#include<stdlib.h>
int main(void)

{
	
	int n,i,*a;

	printf("Enter size of array:");
	scanf("%d",&n);

	a=calloc(sizeof(int),n);
	printf("Enter %d Elements:",n);
	for(i=0;i<n;i++)

	{

		scanf("%d",a+i);

	}

	printf("Array elements are:\n");
	for(i=0;i<n;i++)
	
	{

		printf("%d ",*(a+i));

	}
	
	return 0;

}

			
				
			

Program Explanation

calloc() is predefined function allocates memory of specified bytes.

Number of bytes is specified as (4,n), it means n 4 bytes.

Since we are using integers, specified as 4 bytes.

*a denotes first four bytes, *(a+1) denotes second four bytes, *(a+2) denotes third four bytes and so on., i is initialized to 0 and incremented by 1 at each iteration of both the for loops.

First for loop reads n input numbers from user and stores them in array a[] from location 0 to n-1

Second for loop prints the n elements of array located from 0 to n-1.

Comments

19csa39@karpagamtech.ac.in
not clearly understanding, And give more explaination in one videos .
19csa39@karpagamtech.ac.in
not clearly understanding, And give more explaination in one videos .
Tharun19
The explanation for the program is very easy . It is very useful to understand because i just learned the basics in programming , It is very easy for understanding for my basics level.
19csa39@karpagamtech.ac.in
not clearly understanding, And give more explaination in one videos .